bugfix> html > 投稿

create-react-app を使用して反応アプリを作成しましたユーティリティですが、ノードモジュールをインポートすると、次のようなエラーが表示されます:

./node_modules/@nross/react-vega/src/VegaLite.js
Module parse failed: Unexpected token (17:2)
You may need an appropriate loader to handle this file type.
|   onParseError,
|   children,
|   ...otherProps
| }) => {
|   const adjustedSpec = { ...spec };

そして、 babel-loader をインポートするとき私はノードモジュールをインポートしているファイルにそれから私にエラーを与えています:-

Failed to compile.
./node_modules/babel-core/lib/helpers/resolve.js
Module not found: Can't resolve 'module' in 'C:\VegaDemo\my-app\node_modules\babel-core\lib\helpers'.