bugfix> dart > 投稿

通常、次のようなものを追加する必要があります

dependencies:
  camera: "^0.2.0"

pubspec.yamlファイルに。バージョン番号を含めないとどうなりますか?それは小さなことですが、通常、コードを見つけてテストしたいと思います。上部に、次のようなものが表示されます>> 

import 'package:camera/camera.dart';

バージョン番号を見つけるためにパッケージのホームページにアクセスする必要がありますか?

回答 2 件
  • any を使用できます

    dependencies:
      camera: any
    
    

    制約を厳しくすると、 packages get が簡単になります / packages upgrade  一致するバージョンを検索することはソリューションスペースを削減するためですが、単純な例では通常は問題になりません。

    pub  最近 any を作成する改善されたソルバーを取得しました   pub があった場所よりもはるかに少ない問題  多くの場合、 any のときにタイムアウトしました  使われた。

  • https://www.dartlang.org/tools/pub/dependenciesに従って

    Based on what data you want to provide, you can specify dependencies in two ways. Theshortestway is to just specify a name:

    dependencies:
      transmogrify:
    
    

    This creates a dependency on transmogrify thatallows any version, and looks it up using the default source, which is pub.dartlang.org. To limit the dependency to a range of versions, you can provide a version constraint:

    依存関係:   transmogrify:^ 1.0.0

    This creates a dependency on transmogrify using the default source and allowing any version from 1.0.0 to 2.0.0 (but not including 2.0.0). See Version constraints and Caret syntax for details on the version constraint syntax.

    私の質問に対する本当の答えは、通常、メジャーバージョン番号の比率を指定するのが最善だと思う例:^ 1.0.0 == 1.0.0<2.0.0。つまり、このプログラムは機能し、テストされており、大きな変更がない限り、このライブラリの依存関係で動作し続けます。

あなたの答え